[Webfunds-commits] java/webfunds/client WalletContext.java
Jeroen C. van Gelderen
gelderen@cypherpunks.ai
Thu, 1 Jun 2000 17:12:02 -0400 (AST)
gelderen 00/06/01 17:12:02
Modified: webfunds/client WalletContext.java
Log:
Method getPluginManager sorts just after getAddressBook.
Revision Changes Path
1.5 +2 -2 java/webfunds/client/WalletContext.java
Index: WalletContext.java
===================================================================
RCS file: /home/webfunds/cvsroot/java/webfunds/client/WalletContext.java,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- WalletContext.java 2000/05/28 02:52:01 1.4
+++ WalletContext.java 2000/06/01 21:12:01 1.5
@@ -1,4 +1,4 @@
-/* $Id: WalletContext.java,v 1.4 2000/05/28 02:52:01 iang Exp $
+/* $Id: WalletContext.java,v 1.5 2000/06/01 21:12:01 gelderen Exp $
*
* Copyright (c) 2000 Systemics Inc. All rights reserved.
*/
@@ -18,10 +18,10 @@
public interface WalletContext
{
public Addressbook getAddressbook(WalletInterface wi);
+ public PluginManager getPluginManager(WalletInterface wi);
public SecureRandom getSecureRandom();
public Store getStore(WalletInterface wi) throws StoreException;
public UInterface getUInterface(WalletInterface wi);
- public PluginManager getPluginManager(WalletInterface wi);
// XXX: ChangeContractStore is misnamed and prolly too specific.